Symptom
In some Anveo Mobile App installations using Microsoft Dynamics NAV 2013 (not R2), Microsoft Dynamics NAV server crashes using the SAVEASPDF-function during synchronization process while SAVEASPDF is working properly outside Anveo.
Cause
This is caused by an internal error in Microsoft Dynamics NAV, showing the clr.dll as the reason in Windows Event Log.
Solution
Download an updated version of the WebServiceHelper.dll AddIn from the release files in Anveo Partner Portal, stop your Microsoft Dynamics NAV web services, replace the file in your AddIn folder and start your Microsoft Dynamics NAV servers.
Note
The updated version is required for Microsoft Dynamics NAV 2013 (not R2) only. However, the Anveo Health Check will throw an error message on not fitting dll versions. It is okay to ignore these messages.
Article updated on May 3 with a final solution.